mount NTFS partition (windows XP partition 2) on tmhcm01 hot spare hdd (9.1.1)
- ntfs-3g -o umask=0000 /dev/da1s2 /mnt/R1/tm01
Mount NTFS partition as system start (9.1.1)
- nano /etc/fstab
- insert this line at the end of file : /dev/da1s2 /mnt/R1/tm01 ntfs rw,late,mountprog=/usr/local/bin/ntfs-3g 0 0
- mount -uw /
- cp /etc/fstab /conf/base/etc/fstab
- mount -r /
- reboot freenas to check if it works
viewing the current state of Interfaces
| To install NTFS-3G if you don't have it on, do: # portmaster sysutils/fusefs-ntfs
Next, create a symbolic link from the newly-installed /usr/local/bin/ntfs-3g into /usr/sbin/ : # ln -s $(which ntfs-3g) /usr/sbin/mount_ntfs-3g
Modify your /etc/rc.conf to contain: fusefs_enable="YES"
Provided you know on which hard-disk (based on make/model/capacity of the device) your NTFS partition resides, you can figure out it’s exact device node in FreeBSD: # egrep 'ad[0-9]|cd[0-9]|da[0-9]' /var/run/dmesg.boot
aacd0 on aac0 aacd0: 953869MB (1953525168 sectors) aacd1 on aac0 aacd1: 76315MB (156293120 sectors) aacd2 on aac0 aacd2: 238475MB (488397168 sectors) da0 at ahc0 bus 0 scbus2 target 0 lun 0 da0: <IBM-ESXS MAN3184MP F 5408> Fixed Direct Access SCSI-3 device da0: 160.000MB/s transfers (80.000MHz DT, offset 127, 16bit) da0: Command Queueing enabled da0: 17357MB (35548320 512 byte sectors: 255H 63S/T 2212C) da1 at ahc0 bus 0 scbus2 target 1 lun 0 da1: <IBM-ESXS DTN036W3UWDY10FN S27P> Fixed Direct Access SCSI-3 device da1: 160.000MB/s transfers (80.000MHz DT, offset 127, 16bit) da1: Command Queueing enabled da1: 34715MB (71096640 512 byte sectors: 255H 63S/T 4425C) GEOM_ELI: Device aacd1p1.eli created. My NTFS partition resides on a 34GB IBM SCSI drive, da1s2 . To confirm that /dev/da1 does indeed contain the NTFS partition, do:
# gpart show -p da1 => 63 71096577 da1 MBR (33G) 63 35664237 da1s1 ntfs (17G) 35664300 35423325 da1s2 ntfs [active] (16G) 71087625 9015 - free - (4.4M) To mount the partition manually, do: # ntfs-3g /dev/da1s2 /mnt/R1/tm01
Finally, add the appropriate line to /etc/fstab to have the NTFS partition mounted at the next system boot. For instance, my /etc/fstab contains: /dev/da1s2 /mnt/R1/tm01 ntfs rw,late,mountprog=/usr/local/bin/ntfs-3g 0 0 |
---|